Skip to content
07-848 2005

V-Ray for Maya

Menu Integration

This page provides information on how V-Ray integrates into the standard Maya menus.

Last updated 19 March 2026

This page provides information on how V-Ray integrates into the standard Maya menus.

Overview

V-Ray provides a menu on its own in Maya's toolbar, where you can find some commonly used V-Ray components.

In addition, there are a number of items to the Maya menus, in particular the File, Create, Windows, Lighting/Shading, and viewport Panels menus. Here you can create V-Ray lights, geometric objects, etc.

UI Paths

||Create menu|| > Lights

||Viewport|| > Panels menu > Panel (available only for versions prior Maya 2017)

||Windows menu|| > Rendering Editors > V-Ray

||Lighting/Shading menu||

||File menu|| > Export All... > Export All Options > General Options > File type > V-Ray Scene

||Create menu|| > V-Ray