Skip to content
07-848 2005

V-Ray for Unreal

Toubleshooting

This page gives an outline of how to troubleshoot and report issues with V-Ray for Unreal.

Last updated 25 February 2026

This page gives an outline of how to troubleshoot and report issues with V-Ray for Unreal.

Overview

All processes and events that are executed in Unreal are exported to the Output and Message Logs. From the Output log you can filter the shown information via the Categories flags.

UI Paths

||Window|| > Developer Tools > Output Log

Click here to expand for a screenshot...

||Window|| > Developer Tools > Message Log

Click here to expand for a screenshot...

V-Ray Log

You can see all messages related to V-Ray for Unreal in the VRayLog Category in the Output Log. You can apply a VRayLog filter or a string filter VRayLog to get only the V-Ray related messages.

V-Ray Message Log

You can see all related V-Ray messages in the Message Log accessible from the Developers Tool of the Window menu.

Issue Reporting Guide

When reporting issues provide as much information regarding the problem as possible.

Below are listed the files, folders and the required additional information that will be useful:

  • Steps to reproduce the problem
  • The log from the Output window (||Window|| > Developer Tools > Output Log), preferably filtered by "VRayLog".
  • Content of PROJECT_NAME/Saved/Crashes and PROJECT_NAME/Saved/Logs folders
  • VRay.dmp located in %temp% (may not exist)
  • KernelBase.dll and ntdll.dll located in C:\Windows\System32
  • Test project/scene that reproduces the problem
  • Screenshot(s) of the Unreal editor's viewport
  • Screenshot(s) of the V-Ray settings panel, details panel, or any other UI that is appropriate for the issue
  • Screenshot(s) of the VFB
  • Hardware specs of your workstation

To report an issue you can go to any of the following places: