Skip to content
07-848 2005

V-Ray for 3ds Max

V-Ray Frame Buffer

This page provides information on the V-Ray Frame Buffer and its features.

Last updated 23 June 2026

This page provides information on the V-Ray Frame Buffer and its features.

Overview

The V-Ray Frame Buffer (VFB) is a second-generation V-Ray virtual frame buffer.

VFB is much more than a render image holder window. The new enhanced version provides a higher level of post processing adjustments and ability to modify your scene from inside the VFB. Here is a list of old and new benefits you should know:

  • Image preview:
    Loads render elements channels via a dropdown list;
    Works with display corrections;
    Loads various 8bit and 32bit file formats, including V-Ray resumable files;
    Image comparison between 2 or 4 renders;
  • Image management:
    Keeps the rendered image in full 32-bit floating point format;
    Can store history of rendered images with their post rendering corrections;
    Can save corrected output to various image formats;
  • Image editing and post processing:
    Set Color Corrections to rendered image and its elements;
    Composite mode for Back to Beauty workflow including layers corrections;
    LightMix control on lights contribution in the rendered image;
    Applying Proportion Guides on the rendered image;
  • Scene editing:
    Can modify actual light values by transferring updated intensity and color from LightMix mode;
    IPR camera navigation and focus control from inside VFB;
  • Denoiser control;
    Region rendering control and test resolution;
    Option to choose the order in which the buckets are rendered;
    Automatic render resolution adjustment in IPR when the VFB window is resized;
  • Collaboration:
    Shares images with other Chaos users in Chaos Cloud Rendering.

To use the VFB for rendering, turn on the Enable built-in frame buffer option in the Frame buffer rollout under the V-Ray tab in the Render Setup window.

VFB also has some limitations, which are listed in the V-Ray Frame Buffer section below.

VRay7.3_VFB_overview.jpg

UI Paths

Max2024_VRay6.2_VFB_UI_toolbar
Max2024_VRay7_VFB2_ShowLastVFB_button
Max2024_VRay7_VFB_Menu

VFB Menu

The V-Ray Frame Buffer menu holds the main frame buffer commands. Some of the options are also available in the VFB toolbar for quick access.

Menu

Menu Options

Menu

Menu Options

File

Save current channel – Saves the currently loaded channel to an image file format. Note that color correction layers are not saved.

Save all image channels to separate files – Saves all the render elements to separate files. Select the options () button to open a menu with more settings.

Save all image channels to single file – Saves the image to a single multi-channel EXR or .vrimg file.

Load image – Opens an image file to be previewed in the V-Ray Frame Buffer.

Batch image processing – Allows processing of multiple .vrimg files with the same layer tree changes at the same time.

Upload image to Chaos Collaboration – Uploads an image to Chaos Cloud Collaboration for sharing and commenting.

Enhance image on Chaos Collaboration – Automatically exports the image to an EXR file in the Chaos Collaboration tab and from there you can send it for enhancement to Chaos Cloud Collaboration. Note that a VRayEnhancerData render element must be added beforehand. To hide this function, you can use the CHAOS_DISABLE_GEN_AI Environment Variable.

Upload image to Chaos Veras – Uploads an image to Chaos Veras for AI editing.

Recent Files – Displays a list of the recently opened files.

Save all image channels to separate files options

Save VFB color corrections to render elements – When enabled, all color corrections are saved to the render channels (as opposed to only the RGB and effectsResult channels).

Batch Image Processing

Input folder – Specifies a path to start images.

Output folder – Specifies a path for the output images.

Layer preset – Specifies a layer tree corrections preset.

Output filenames suffix – Specifies a suffix added to the output image filenames.

Overwrite existing – Enables overwrite of existing files with the same name in the output folder.

Render

Start interactive rendering – Starts IPR.

Abort rendering – Cancels the current rendering.

Render – Starts rendering.

IPR Debug Shading – Enables the Debug shading/Isolate selected options in IPR. The submenu gives access to the following modes:

Isolate Selected – Renders only the selected object(s), while the rest of the scene is rendered black. You can also select material or texture nodes to isolate all objects with the assigned shader;
Isolate Locked Selection – Locks the selection to the currently selected object(s). Changes to other objects or lights can be made while rendering the same isolated object(s);
Lightning – Renders only the light contribution in the scene;
Ambient Occlusion – Renders ambient occlusion for the scene;
Wireframe – Renders the scene objects in wireframe;
Normals – Shows the normals of the scene objects;
UVs – Displays the UV coordinates of the scene objects.

Image

Follow mouse – Renders the closest bucket found to the mouse pointer, when using the bucket image sampler. If the progressive sampler is used, V-Ray samples the closest pixels to the mouse pointer.

Follow mouse – Drag the mouse over the VFB while rendering to change what part of the image is sampled first;
Follow mouse (locked) – Locks the bucket (or sampling) starting point.

Copy current channel to clipboard – Copies the current channel to the clipboard.

Duplicate to host frame buffer – Creates a 3ds Max virtual frame buffer copy of the current VFB.

Clear image – Clears the contents of the frame buffer. This is useful when starting a new render to prevent confusion with the previous image.

View

Display color space – Specifies the color space, in which the image is displayed.

None – Does not specify a color space;
sRGB – Displays the image in sRGB color space;
OCIO – Displays the image in a color space loaded from an OCIO configuration file;
ICC – Displays the image in a color space loaded from an ICC configuration file;
Gamma 2.2 – Displays the image in Gamma 2.2 color space.

Zoom VFB – Zooms in/out the rendered image in the VFB.

Zoom 50% – Zooms out to 50%;
Zoom 100% – Zooms to 100%. Alternatively, double-click in the VFB with the left mouse button;
Zoom 150% – Zooms in to 150%;
Zoom to fit – Zooms the current image to fit in the VFB. If Render Region is active – zooms to the region.

Channels – Chooses which channels to see.

View red channel – Displays the red channel;
View green channel – Displays the green channel;
View blue channel – Displays the blue channel;
Switch to alpha channel – Displays the alpha channel;
Monochromatic mode – Displays the image in monochromatic mode.

Test resolution – Enables test resolution in VFB. The submenu allows choosing a percentage of the render resolution to set as the test resolution. You can choose between 10%, 25%, 50%, 75%, 110%, 125% and 150%. Note: This only affects V-Ray and does not affect the native 3ds Max test resolution setting found under 3ds Max's Render Setup dialog.

Color clamping – Opens the color clamping submenu options:

Force color clamping – Forces color clamping;
View clamped colors – Displays the clamped colors.

Use pixel aspect – Enables visualization of the pixel aspect ratio.

Flip – Mirrors the image in the VFB. This is a view only option, the flipped image cannot be exported. This function is only active while holding the menu button or the hotkey for the corresponding type of flip. The effect does not interrupt interactive rendering.

Flip horizontally – Mirrors the image horizontally.

Flip vertically – Mirrors the image vertically.

Panorama View – Shows the image in 360° view.

Show History – Shows the History panel.

Show Layers – Shows the Layers panel.

Show Histogram – Shows the Histogram panel.

Options

VFB settings – Opens the VFB Settings window where you can adjust settings for Render View, Render Region Controls, History and Filter/Layer presets.

VFB Toolbar

This dropdown list gives access to render elements rendered for the scene. The selected render element is displayed in the VFB. By default, the RGB color and Alpha render elements are available. Any additional render elements that have been added to the scene also appear in the dropdown list.

This dropdown list gives access to render elements rendered for the scene. The selected render element is displayed in the VFB. By default, the RGB color and Alpha render elements are available. Any additional render elements that have been added to the scene also appear in the dropdown list.

Displays the coordinates of the mouse pointer.

Specifies the sampled area size. Click the arrow to open a context menu with the available sampled area sizes: 1x1, 3x3, 5x5, and 7x7.

Signifies whether color and display corrections are applied (RGB) or not (Raw) when showing the sampled pixel values at the current mouse pointer position.

Displays the RGB pixel values at the current mouse pointer position before applying any color corrections.

Specifies RGB values. Click the arrow to open a context menu with the available options.

None – Does not specify the RGB value.
HSV – Specifies the Hue, Saturation and Value of the pixel under the current mouse position.
Web – Specifies the HEX of the pixel under the current mouse position.
8bit – Specifies the 8bit color palette of the pixel under the current mouse position.

Displays the Hue, Saturation and Value of the pixel under the current mouse position when HSV is selected.

Displays the HEX of the pixel under the current mouse position when Web is selected.

Displays the 8bit color palette of the pixel under the current mouse position when 8bit is selected.

Locks the mouse pointer coordinates and displays information for the selected pixel.

Locks the mouse pointer coordinates and displays information for the selected pixel.

Shows corrected colors.

Shows the V-Ray Log which contains messages about the render process. The V-Ray Log is also available in the Log tab.

Displays the red channel.

Displays the green channel.

Displays the blue channel.

Displays the Alpha channel.

Opens Chaos Veras and sends the latest render from VFB to be used as a generation source. Uses the RGB channel. To hide this function, you can use the CHAOS_DISABLE_GEN_AI Environment Variable.

Automatically exports the image to an EXR file in the Chaos Collaboration tab and from there you can send it for enhancement to Chaos Cloud Collaboration. Note that a VRayEnhancerData render element must be added beforehand. To hide this function, you can use the CHAOS_DISABLE_GEN_AI Environment Variable.

Saves the image to disk. Select and hold the icon to bring up the submenu:

Save current channel – Saves the current channel to an image file format;
Save all image channels to separate files – Saves all the render elements into separate files. Click the options () button to open a menu with more options.
Save all image channels to single file – Saves the image into a single multi-channel EXR or .vrimg file.
Upload image to Chaos Collaboration – Uploads an image to Chaos Cloud Collaboration for sharing and commenting.

Clears the contents of the frame buffer. This is useful when starting a new render to prevent confusion with the previous image.

Renders the closest bucket found to the mouse pointer, when using the bucket image sampler. If the progressive sampler is used, V-Ray samples the closest pixels to the mouse pointer. With this option enabled, you can right-click on the image and select Lock bucket starting point to lock the bucket (or sampling) starting point.

Enables/disables test resolution in the VFB. Select and hold to bring up the submenu to select the percentage of the render resolution to set as the test resolution. Note: This only affects V-Ray and does not affect the native 3ds Max test resolution setting found under 3ds Max's Render Setup dialog.

Renders rectangular regions in the VFB. See the Region Render section for more information.

Renders multiple polygonal regions in the VFB. See the Region Render section for more information.

Enables the Debug shading/Isolate selected options in IPR. Select and hold to choose between the different modes:

Isolate Selected – Renders only the selected object(s), while the rest of the scene is rendered black. You can also select material or texture nodes to isolate all objects with the assigned shader;
Isolate Locked Selection – Locks the selection to the currently selected object(s). Changes to other objects or lights can be made while rendering the same isolated object(s);
Lightning – Renders only the light contribution in the scene;
Ambient Occlusion – Renders ambient occlusion for the scene;
Wireframe – Renders the scene objects in wireframe;
Normals – Shows the normals of the scene objects;
UVs – Displays the UV coordinates of the scene objects.

Starts IPR. If there is more than one camera in the scene, hold left mouse button to display a list of the available cameras.

Cancels the current render. When the render is cancelled, the Denoiser is not applied or saved, equivalent to the behavior of the Cancel button in the Rendering window.

Stops the ongoing rendering at its current state. It takes the render's current state as valid to perform all post-rendering tasks such as post-effects or image output saving.

Starts rendering. If there is more than one camera in the scene, hold left mouse button to display a list of the available cameras.

When pressing Shift + this button, starts Render last and the last rendered viewport/camera is rendered.

Pauses interactive rendering when using V-Ray GPU.

Refreshes interactive rendering.

Render History

The V-Ray VFB keeps a history of previously rendered images, and lists each with a number, thumbnail, and textual details in the Render history panel. Up to four images can be called from the history to be compared in the VFB (as shown below). History files are stored as .vrimg files in a user-specified folder. Render history settings can be configured in the VFB Settings window.

Enables or disables image A/B vertical comparison. Select images A and B from the render history.

Enables or disables image A/B vertical comparison. Select images A and B from the render history.

Enables or disables image A/B horizontal comparison. Select images A and B from the render history.

Enables or disables image A/B/C/D comparison. Select images A, B, C and D from the render history.

Saves the current image from the VFB to the render history. The image is placed at the top of the render history list.

Loads the selected image from the render history to the VFB.

Removes the selected image from the render history.

A search field where you can filter the images based on the scene paths and notes. The filter text is selected when pressing Enter from the keyboard.

A search field where you can filter the images based on the scene paths and notes. The filter text is selected when pressing Enter from the keyboard.

Max2024_VRay7_VFB_Comparison
Max2024_VRay7_VFB_History_EnableLink

If the Render History is disabled, a link to the Settings History tab is displayed in the panel.

Right-Click Menu

Edit note – Allows adding a text comment to the image; the comment appears below the image.

Set A – Sets the render as A image for A/B comparison.

Set B – Sets the render as B image for A/B comparison.

Load to VFB – Loads the selected image in the VFB (same as double-clicking on the image).

Delete – Deletes the selected image from history. The image is moved to the system's Recycle Bin and can be restored from there if needed.

Load layers – Loads the layer tree preset of the selected image.

Load V-Ray settings – Loads the V-Ray settings used for the saved render.

Compare V-Ray settings – Opens the Compare V-Ray settings dialogue, where you can compare the render settings of saved renders.

Image Info – Opens a window containing detailed information about the image, including, but not limited to Camera, Aperture, FOV, Target Distance, V-Ray version, render time, and also custom attributes specified in the exr metadata of VRayOptionRE render element. Have in mind that the camera values are saved in system units. Also, the vrayrevison info displayed in the list is not related to the saved .vrimg file but to the current V-Ray build installed for 3ds Max.

Image Info Window

Open scene – Opens the rendered scene in the viewport. This option works as long as the initial file path of the scene has not changed after the render.

Copy scene path – Copies the full path to the scene.

Copy project path – Copies the full path to the project.

Show in folder – Opens a file explorer with the respective image selected.

Upload the image to Chaos Veras – Uploads an image to Chaos Veras for AI editing.

Upload image to Chaos Collaboration – Uploads an image to Chaos Cloud Collaboration for sharing and commenting.

Enhance image on Chaos Collaboration – Sends your render to Chaos Collaboration for AI enhancement.

Reload history – Re-reads the history image list. This may be needed if the history folder is updated outside of 3ds Max (e.g. from another 3ds Max session).

Save images as – Opens the Save history images to files window, that provides a single-point multi-save of History files. Save options can be set - file type, image format options, destination path, custom naming.

Select all – Selects all History images.

Select none – Deselects the selected History images.

Select invert – Inverts the current selection of History images. Images that were previously selected are deselected, while those that were not selected are now marked as selected.

VRay7.4_VFB_HistoryPanel_ContextMenu.png

The History panel with notes/name, resolution/time, and shortcut key info is displayed.

Right-clicking on an image in the VFB history brings up a pop-up menu with some useful options.

Max2024_VRay7_VFB_History_menu

Save History Images To Files

File types – Defines the file type of the saved images.

Image format options – Provides additional control settings for each file type.

Destination folder – Specifies a path for the saved images.

Use custom filename prefix – Enables custom naming use. Custom tags can be used, when setting the custom filenames - typing '<' shows a list of available tags, including all Image Info fields. Example: Custom filename - <Max project file name>_<note>_<engine> → Resulting filename - simple-scene_001.max_noted-info_CPU.vrimg.

File overwrite strategy – Defines how to manage files that share the same names. Select between Replace files, Skip existing and Ask confirmation.

Show in explorer on completion - When enabled, opens a file explorer to the saved images directory on process end.

Select all – Selects all History images.

Select none – Deselects the selected History images.

Select invert – Inverts the current selection of History images. Images that were previously selected are deselected, while those that were not selected are now marked as selected.

Save items – Starts the save images process. The save process can be cancelled.

Cancel – Closes the Save history images window

Max2026_VRay7.2_VFB_History_SaveImages.png

Filters

The V-Ray VFB provides a variety of filter presets.

The Filters panel preset previews provide easy check of multiple color corrections scenarios. Preview thumbnails are auto updated on render end. Manual reload from the button or right-click option is needed for image load from History. Applying one of the filters, adds it as a folder on top of the layer tree. On the next filter load the top preset folder in the layer tree is replaced by the new corrections.

To create custom filters in the VFB Layers panel right-click on a folder containing correction layers and save it as a .vlpdir file. Change presets directory from V-Ray Frame Buffer > Options menu > VFB Settings > Filter/Layer presets > Path. Personal custom filters are now shown in the panel and can be loaded quickly.

Refreshes the preview thumbnails.

Refreshes the preview thumbnails.

Applies the selected thumbnail preset folder to the layer tree.

A text search field which provides fast location of the desired filters. The filter text is selected when pressing Enter from the keyboard.

A text search field which provides fast location of the desired filters. The filter text is selected when pressing Enter from the keyboard.

VRay7.3_VFB_Filters.gif

If a Filters folder path has not been specified, a link to the Filter/Layer presets tab is displayed in the panel.

Histogram

The Histogram provides a visual representation of the distribution of the RGB, Luminance, and Intensity channels across the image.

Mode – Specifies the Display mode.

RGB – Displays the Red, Blue, and Green channels overlapping each other.
RGB Parade – Displays Red, Blue, and Green channels separately.
Luminance (Y) – Displays the Luminance channel.
RGB + Y – Displays Red, Blue, Green, and Luminance channels overlapping each other.
RGB + Y Parade – Displays Red, Blue, Green, and Luminance channels separately.
Intensity(I) – Displays the Intensity channel.
RGB + Y + I – Displays Red, Blue, and Green, Luminance, and Intensity channels overlapping each other
RGB + Y + I – Displays Red, Blue, and Green, Luminance, and Intensity channels separately.

VRay7.3_VFB_Histogram.png
VRay7.3_VFB_Histogram_Settings.png

Settings () – Opens the Settings dropdown menu.

Use log scale – Displays data in logarithmic scale. It’s useful when displaying broad range of pixel data with significant differences among the magnitudes.
Use smooth histogram – Displays the information as a smooth curve instead of bars.(default)
Show color components stats – Enables a widget below the graph with visual representation for min/max and median values spread in each channel. Hover over a channel to display stats as a tooltip.

See a Show color components stats example.

VRay7.3_VFB_Histogram_ColorComponents.gif

Show outside view count – This label shows the number of pixels that have values falling outside the histogram range. It might indicate the presence of extremely bright pixels, such as those over a value of 16.0f, which can occur like a VRaySun disk. Click the label to select these pixels.
Show only SDR range – Displays only the SDR range of the image. Click SDR in the header to toggle it on or off.
Show SDR clip warning – Indicates possible clipping in shadow and highlight areas in the image. Select one of the clipping checkboxes placed at the top of the histogram to preview it. Highlights and shadows clipping warnings are displayed simultaneously, where the red color stands for black warning and blue for white warning.
Visualize HDR range – Toggles histogram mode where pixels in the HDR range are color coded depending of the f-stop range. Click on the HDR in the header to toggle it on or off.
Premultiplied alpha – Weights semi-transparent pixels in the histogram data and discards transparent pixels entirely.

Dock/Undock – Undocks and docks the Histogram.

VRay7.3_VFB_Histogram_Settings_Dropdown.png
VRay7.3_Histogram_controls.gif
VRay7.3_VFB_Histogram_Clipping.gif

Layers

The redesigned V-Ray Frame Buffer includes a suite of color corrections and tools for adjusting the image. The tools are added as layers and displayed in a layer tree. You can enable or disable a particular tool using the visibility icon (). The icon indicates that a layer is disabled. All layers have a vertical line marker for clear differentiation between fixed and flexible layers. Fixed layers are marked with a grey line, while newly added layers, which can be moved around freely and put into groups, are marked with a blue line.

Layers are only saved to .exr and .vrimg files written through V-Ray's own output. Note that the output in Render Setup > Common tab is written by 3ds Max so .exr files saved from there do not have Layers saved.

When saving layers to an exr/vrimg file, V-Ray writes a flag indicating whether the color corrections are baked in the RGB channel. For example, if you save an exr from the VFB File menu > Save all image channels to single file option, V-Ray creates an .exr file with corrections baked in. It also saves the layers as metadata and the flag that corrections are baked in. When loading images into the Frame Buffer, V-Ray checks if the image has corrections baked (using the flag), and if such are found, the layers are not loaded (from History panel > Load layers option or VFB File menu > Load image option) because this causes double correction.

For more information on using the Layers, see the Layers page

Max2026_VRay7.3_Layers_all.png

Creates a layer. Multiple layers of the same type can be added.

Folder – Allows grouping multiple layers in folders;
Vignette – Adds a vignetting effect to an image;
ICC Profile – Uses an ICC profile file for color corrections;
Filmic Tonemap – Contains different types of mapping curves and gamma corrections. Also allows the selection of a color space;
Lookup Table – Allows loading a LUT file for color transformations;
Curves – Adds a Curves color correction layer;
Color Balance – Adds a Color Balance color correction layer;
Hue/Saturation – Adds a Hue/Saturation color correction layer;
White Balance – Adds a White Balance color correction layer;
Exposure – Adds an Exposure color correction layer;
Constant – Adds a solid color that can be used to achieve an effect on another layer (for example to multiply by the constant);
Render Element – Selects a render element (with ability to apply mask on it) from your image that you can use in compositing;
Image – Adds an image color correction layer;
Integer mask – Mask is used with integer render elements like VRayRenderID, VRayObjectID, and VRayMtlID Render Elements;
MultiMatte mask – Mask is based on the MultiMatte Render Element;
Image alpha mask – Mask based on the image alpha channel;
Cryptomatte mask – Mask is based on the VRayCryptyomatte Render Element;
Proportion Guide – Adds a proportion guide layer.

For more information, see the Layers page.

Creates a layer. Multiple layers of the same type can be added.

Folder – Allows grouping multiple layers in folders;
Vignette – Adds a vignetting effect to an image;
ICC Profile – Uses an ICC profile file for color corrections;
Filmic Tonemap – Contains different types of mapping curves and gamma corrections. Also allows the selection of a color space;
Lookup Table – Allows loading a LUT file for color transformations;
Curves – Adds a Curves color correction layer;
Color Balance – Adds a Color Balance color correction layer;
Hue/Saturation – Adds a Hue/Saturation color correction layer;
White Balance – Adds a White Balance color correction layer;
Exposure – Adds an Exposure color correction layer;
Constant – Adds a solid color that can be used to achieve an effect on another layer (for example to multiply by the constant);
Render Element – Selects a render element (with ability to apply mask on it) from your image that you can use in compositing;
Image – Adds an image color correction layer;
Integer mask – Mask is used with integer render elements like VRayRenderID, VRayObjectID, and VRayMtlID Render Elements;
MultiMatte mask – Mask is based on the MultiMatte Render Element;
Image alpha mask – Mask based on the image alpha channel;
Cryptomatte mask – Mask is based on the VRayCryptyomatte Render Element;
Proportion Guide – Adds a proportion guide layer.

For more information, see the Layers page.

Deletes the selected layer(s).

Saves a layer tree preset. The following presets are available: vfbl, vlpdir, vlpct, vlpexp, vlpwb, vlphsl, vlpcl, vlpcrv, vlplut, vlptm, vlpicc, vlpvgnt, vlpsrc, vlpdzr, vlpshb, vlplfx). For more information, refer to the Save and Load Presets section.

Loads a layer tree preset. The following presets are available: vfbl, vlpdir, vlpct, vlpexp, vlpwb, vlphsl, vlpcl, vlpcrv, vlplut, vlptm, vlpicc, vlpvgnt, vlpsrc, vlpdzr, vlpshb, vlplfx, vccglb). For more information, refer to the Save and Load Layer Presets section.

Quick access to the Layer/Filter Presets.

Undo various actions related to layers such as create, delete, reorder, or modify a layer.

Redo various actions related to layers such as create, delete, reorder, or modify a layer.

VRay7.3_VFB_AddLayerList.png

Each layer has a context menu. Right-click to display it.

Command

Description

Command

Description

Reset

Resets all changes done to the selected layer.

Save

Saves the layer as a preset.

Load

Loads a preset for the selected layer.

Delete

Deletes the selected layer.

Save as LUT

Bakes all the color corrections to a LUT file.

New Layer

Creates a new layer.

Duplicate

Duplicates the selected layer.

Blend Modes

Specifies how the selected layer blends with the result from all layers below it.

VRay7.3_VFB_LayerContext.png

Save and Load Layer Presets

There are several types of layer presets: presets for a single layer, presets for a folder of one or more layers, and presets for a full layer tree. You can also load a legacy preset for global color corrections (vccglb) saved with the previous VFB 1 available in earlier V-Ray versions.

Max2020_VRay5_VFB_Load_Layers_Tree_Preset_button.png

You can only load vccglb preset files via the Load layer tree preset () button, but you cannot save them with the new VFB.

Max2020_VRay5_VFB_Save_Layers_Tree_Preset_button.png
Max2020_VRay5_VFB_Load_Layers_Tree_Preset_button.png

The preset for a full layer tree (vfbl) can be saved or loaded from the respective Save layer tree preset () and Load layer tree preset () buttons in the Layers tab.

Max2020_VRay5_VFB_Load_Layers_Tree_Preset_button.png

The presets for a folder (vlpdir) can be saved and loaded from the context menu of a folder. Such presets can also be loaded or previewed from the Layer/Filter presets menu if it points at its location or through the Load layer tree preset () button.

The presets for a single layer (vlpct, vlpexp, vlpwb, vlphsl, vlpcl, vlpcrv, vlplut, vlptm, vlpicc, vlpvgnt, vlpsrc, vlpdzr, vlpshb, vlplfx) can be saved or loaded from the context menu of an existing layer: right-click on the layer and select Save or Load.

The following presets for single layers are available:

vfbl – A preset for a full layer tree.

vlpdir – A preset for a folder of one or more layers. The vlpdir presets are saved from the context menu of a folder.

vlpct – A preset for a single Constant layer. Can be saved from the context menu of the Constant layer.

vlpexp – A preset for a single Exposure layer. Can be saved from the context menu of the Exposure layer.

vlpwb – A preset for a single White Balance layer. Can be saved from the context menu of the White Balance layer.

vlphsl – A preset for a single Hue/Saturation layer. Can be saved from the context menu of the Hue/Saturation layer.

vlpcl – A preset for a single Color Balance layer. Can be saved from the context menu of the Color Balance layer.

vlpcrv – A preset for a single Curves layer. Can be saved from the context menu of the Curves layer.

vlplut – A preset for a single Lookup Table layer. Can be saved from the context menu of the Lookup Table layer.

vlptm – A preset for a single Filmic tonemap layer. Can be saved from the context menu of the Filmic tonemap layer.

vlpicc – A preset for a single ICC profile layer. Can be saved from the context menu of the ICC profile layer.

vlpvgnt – A preset for a single Vignette layer. Can be saved from the context menu of the Vignette layer.

vlpsrc – A preset for a single Source layer. Can be saved from the context menu of the Source layer.

vlpdzr – A preset for a single Denoiser layer. Can be saved from the context menu of the Denoiser layer.

vlpshb – A preset for a single Sharpen/Blur layer. Can be saved from the context menu of the Sharpen/Blur layer.

vlplfx – A preset for a single Lens Effects layer. Can be saved from the context menu of the Lens Effects layer.

Stats

The V-Ray Frame Buffer allows monitoring of different statistics and information about your scene in the Stats panel. The exact contents of the Stats change depending on the scene, the rendering mode (interactive vs production, bucket vs progressive) and others.

Max2024_VRay7_VFB_Stamps

Log

The Log panel provides messages about the render process. Verbosity control is available and you can filter the type of messages shown in the Log: All, Error Only, Error & Warnings, or Error, Warnings & info.

Settings () – Opens the Settings dropdown menu.

Show progress – Shows a completion percent of each task (e.g. building Light Cache).

Wrap – Wraps longer lines in order to avoid horizontal scroll.

Undock – Docks/undocks the Log tab.

Show policy - Determines the conditions for showing the log: Never, Always, On warning/error, On error.

max2026_VRay7.4.1_VFB_LOG_Settings.png

Collaboration

The Collaboration tab provides a collaboration tool for sharing your work with other users. You can upload images from the VFB to the Chaos Cloud Collaboration where other users can add comments and annotations. Starting with V-Ray 7, update 2, you can also send images for AI enhancement to the Chaos Cloud Collaboration.

3dsMax_Indicator.png

Signing in Chaos Cloud Collaboration using your Chaos credentials is required once. After that you are automatically signed in every time you open the Collaboration tab.

When first opening the Collaboration tab, click Upload to enhance to send your render for AI enhancement, or click Upload to share your render with others in Chaos Cloud Collaboration.

3dsMAx_UploadIcon.jpg
3dsMAx_EnhanceIcon.jpg

Following that, you can upload other images via the Upload image to Chaos Collaboration button or some of the other options provided by the VFB. You can send other images for AI enhancement via the Enhance image on Chaos Collaboration button.

Upload to enhance – Converts the image to multichannel EXR internally (including the auto-generated channels by VRayEnhancerData RE). From there the image can be enhanced in Cloud Collaboration.

Upload – Uploads the image to Cloud Collaboration as a PNG file.

Create new project – Creates a project folder where the images are uploaded to the Chaos Cloud Collaboration.

Max2024_VRay7_VFB_CollaborationPrepare

The Collaboration tab has several sections: Upload files containing a list of images for upload, Recent containing recent projects, and Browse with locations where the images are uploaded.

VFB_Collab_RenameImg.jpg

– Renames the current image.

VFB_Collab_DeleteImg.jpg

– Deletes the current image from the upload list.

VFB_Collab_UploadToVFB.jpg

– In the Upload files, uploads the current image in the VFB to Chaos Cloud Collaboration. In Browse, creates a new project or folder.

Upload – Uploads the images to Chaos Cloud Collaboration.

New upload – Clears the Collaboration tab and prepares it for new upload of images.

Open in Chaos Cloud – Opens the uploaded images in Chaos Cloud Collaboration.

Max2024_VRay7_VFB_Collaboration

Example: How to use Cloud Collaboration to fast-forward design reviews in the cloud

www.youtube.com

VFB Shortcuts

These shortcuts navigate through the VFB image. Please note that the VFB window must have the current focus for the shortcuts to have effect:

Mouse

Description

Mouse

Description

Mouse wheel

Zoom in/Zoom out

Double-click left button

Zoom to 100%

Middle button dragging

Pan (hand tool)

Ctrl+Shift+Left click

Zoom in the rendered image

Ctrl+Shift+Right click

Zoom out the rendered image

Keyboard

Description

Global

H

Show/hide history

P

Show/hide only layers tree

Ctrl+L

Show/hide whole right panel

F11

Toggle full screen

S

Show/hide VFB settings

History/Render View

E

Enable history A/B/C/D compare mode

Q

Enable history A/B horizontal compare mode

W

Enable history A/B vertical compare mode

N

Edit a note in VFB History panel

1-9

Load the respective image from the VFB history

Layers/Property Panel

Ctrl+Y

Redo various actions related to layers such as create, delete, reorder, or modify a layer.

Ctrl+Z

Undo various actions related to layers such as create, delete, reorder, or modify a layer.

Layers

Del

Delete layer

Message Log

Message Log

Esc

Close search

Ctrl+F

Activate the Search field in Log tab

Return

Find next

Shift+Return

Find previous

Render View

Esc

Cancel render

Ctrl+C

Copy the VFB image to the Windows clipboard; the image is copied exactly as it appears on the screen (meaning sRGB/LUT/OCIO etc. corrections are applied). The full resolution image is copied to the clipboard, even if the VFB view is zoomed in/out.

Ctrl+O

Load image

L

Lock the mouse pointer coordinates and display information for the selected pixel, i.e. activate the Lock pixel info coordinates button.

Arrow keys

Pan image left, up, right, down

A

Switch to Alpha channel

B

View Blue channel

G

View Green channel

R

View Red channel

Page Down

View next channel

Page Up

View previous channel

*

Zoom to 100%

+ / =

Zoom in

-/_

Zoom out

F

Fit region or whole image in the VFB

M

Hold to flip image horizontally

Shift + M

Hold to flip image vertically

VFB IPR Options

Real Zoom – When enabled, scrolling does not zoom the pixels of the rendered image, but instead moves closer or further from the rendered geometry.

View Navigation – Requires a camera view. Adjusts the view angle from the render in the VFB instead of in the viewport. Simply click and drag in the rendering area of the VFB window.

Pause – Pause/resume rendering when rendering with V-Ray GPU.

Re-initialize – Restart rendering.

Select object (Ctr+Click) – Directly select scene objects by clicking on them in the VFB rendering area. You can use the Ctrl + left mouse button keyboard shortcut instead.

Get object material (Shift+Click) – Pick a scene material from an object that is being rendered. You only need to click on that object in the VFB rendering area and the material editor opens with it. You can use the Shift + left mouse button keyboard shortcut instead.

Set focus distance (Alt+Click) – Sets the target distance for the Depth of Field effect to the location clicked in the VFB rendering area. You can use the Alt + left mouse button keyboard shortcut instead.

Region Render

Region rendering is available in both IPR and Production modes. It allows the isolation of parts from the whole frame for rendering.

Region render

Renders rectangular regions in the VFB.

Region render

Renders rectangular regions in the VFB.

Polygon region render

Renders multiple polygonal regions in the VFB.

Freeform – Selects the Polygon region render mode.

Rectangular – Selects the Region render mode.

Add/Delete vertex – Adds/deletes vertices of a selected polygon.

Delete polygon – Deletes the selected region.

Delete all – Deletes all regions.

Undo/Redo – Undoes/redoes various actions related to the region render shapes.

Max2024_VRay7Beta_VFB_PolygonRegionRender_Menu
Max2024_VRay7Beta_VFB_RegionRender_Preview

Region Render

Max2024_VRay7Beta_VFB_PolygonRegionRender_Preview

Polygon Region Render

Saving Files With Render Region

There are two ways to save the whole frame with the region render.

Single channel .exr files are saved through:

  • Render Setup > V-Ray tab > Frame buffer > Separate render channels (V-Ray ignores 3ds Max's Image Region option residing in the 3ds Max native file output dialog under Setup > OpenEXR Configuration window.)
  • VFB > File > Save current channel

Multi-channel .exr files set to save the whole frame are saved through:

  • Render Setup > V-Ray tab > Frame buffer > V-Ray raw image file + VRayOptionRE with EXR data window set to Whole Image (Multi-channel .exr files set to save full frame instead of just the render region.)
  • VFB > File > Save all image channels to single file

Notes

  • VFB does not display the G-Buffer layers (like Coverage etc.)
  • VFB does not work with strip rendering
  • VFB does not work with rendering to fields
  • Even when the V-Ray VFB is enabled, the 3ds Max VFB is still created and thus takes additional memory. To reduce that memory, uncheck the Get resolution from Max option, set the 3ds Мax resolution to a low value like 100 x 100, and then select your actual output resolution in the V-Ray tab > Frame buffer options in the Render Setup window.
  • If you have selected an output image file from the Common tab of the Render Scene dialog, V-Ray fills out the 3ds Max RFW, and this is saved as your image. If you want to save the V-Ray VFB instead, you should use the Split render channels or Render to V-Ray raw image file option of the V-Ray tab > Frame buffer options in the Render Setup window.
  • The OpenEXR file format is an open file format for high dynamic range images originally developed by Industrial Light and Magic. The official site of the OpenEXR file format is www.openexr.com
  • When using the IPR right-click options, the primary 3ds Max window needs the cursor focus to use Ctrl+Z to Undo.
  • If Lens Effects or the VRayDenoiser render element are enabled, then the RGB Color channel is saved with the name RGB_color and the effectsResult channel is saved as effectsResult when saving all channels from VFB.
  • If an 8-bit file is saved through the VFB or the Render Output / Save image settings, a color space with Gamma 2.2 is embedded into the final output image. If a 32-bit (exr, hdr, tif) image is saved, it remains linear and relies on the external image viewer to handle the display color space.
  • The VFB test resolution is ignored for command-line rendering and Backburner jobs. The Test Resolution button is inactive in IPR if Fit resolution to VFB is enabled.
  • The Enhance image on Chaos Collaboration feature is supported for 3ds Max 2022 and newer.