Skip to content
07-848 2005

KeyShot Studio

Materials

Articles in this section

Advanced

The Advanced material is the most versatile of all KeyShot Studio material types. There are more parameters in this material than in any other. With this variety of parameters, materials such as metals, plastics, transparent or cloudy plastics, glass, leathers and diffuse materials can all be created from this singl...

Materials

Advanced Materials

Materials

Animation Node Types

The Animation nodes are unique in that they allow you to create changing parameters of your materials. When you add an Animation node to your material, it will automatically be added to the animation timeline as well.

Materials

Anisotropic

The Anisotropic material type gives you advanced control over the highlights on the material surface. On other material types that have a single “Roughness” slider, increasing this value causes the highlights on the surface spread out evenly in all directions. Anisotropic gives you control over the highlight shape b...

Materials

Area Light

The power of the light can be controlled in either Watt, Lumen or Lux. Lumen or Lux are recommended for best results. The choice between Lumen or Lux depends on the preferred workflow.

Materials

Assigning Materials

To assign materials to models, drag and drop them from the Materials library onto a part in the Real-time View or in the Scene Tree. Before you drop the material onto the part, you will see a preview of the material on the part beneath the mouse cursor. The material will not be assigned until you let go of the left...

Materials

Axalta Paint

This slider provides controls the reflection on the surface. Increase the value to get more reflection intensity.

Materials

Basic Materials

Materials

Bubbles

The Bubble Limit slider allows you to limit the amount of bubbles used. The limit is per object, not the the overall for the material in the scene. The limit value is expressed in millions.

Materials

Bump Add

Combine two bump texture maps or procedural textures. Control their interaction by defining the Ratio and Weight in which the two bumps are visible.

Materials

Color Adjust

Colorize and/or modify the existing color of a texture map or procedural texture by adjusting Hue, Saturation, Value, and Contrast. Each of these parameters can be textured.

Materials

Color Composite

Color Composite nodes are commonly used create Opacity masks from multiple textures or to add gradients to textures.

Materials

Color Fade

The Color Fade animation node allows you to create changing parameters of any of your custom material color swatches.

Materials

Color Invert

Invert the color of a source texture map or procedural texture. This is commonly done to convert glossiness maps (white = perfectly shiny) to roughness maps (white = maximum roughness), or invert opacity masks.

Materials

Color Key Mask

Mask a specified color within a texture map or procedural texture. Control the strength of the mask by adjusting Tolerance and Fuzziness.

Materials

Color To Number

The Color To Number node converts color values to number values. This is usually done implicitly such that black is zero and white is 1, however there are times where you need more control. This is quite useful, for example, with roughness maps where you can use Color To Number to easily map a gray scale image to go...

Materials

Copying Materials

When copying materials it is important to decide if you want separate versions of the same materials or if the materials should be linked.

Materials

Curve Fade

The Curve Fade animation node allows you to add changing parameters of any of your numerical properties within your custom material. To see the which parameters you can change for a specific node, connect the Curve Fade animation node to the + socket.

Materials

Cutaway

Simply add the geometry you want to use for the cut, place it so it cuts into your model and assign the cutaway material to it.

Materials

Dielectric

Roughness on this type of material will spread out highlights on the surface similar to what you see on non-transparent, materials. However, it also spreads out the light that is transmitted through the material. This is used to create a frosted glass look.

Materials

Diffuse

This setting controls the color of the diffuse material. Select the color box to display the Color Picker and select the desired color.

Materials

Diffuse Parameter

The Diffuse parameter will be found throughout many of the material types.

Materials

Displace

Use the Displace node when you want to transform the surface of the object. Add a Displace node to the Geometry socket of the root Material node, then add a Texture Map to the Displace socket of the Displace node.

Materials

Editing Materials

There are multiple methods of navigating to the material properties to make changes, but all editing is done in the Material Tab of the Project Window.

Materials

Emissive

Hide the emissive material from the camera, but the emissive material will still emit light.

Materials

Flakes

Use Flakes when you want your object to be made up of flakes of a specific material. Add Flake node to the geometry socket of the Root node.

Materials

Flat

Click the color box to launch the Color Picker, which allows you to select the color of the material. The flat material has no shading or other surface properties. It will show the solid color you have selected over the entire part that the material is applied to.

Materials

Fuzz

The Fuzz node enables you to add randomized, hair-like growth from the surface of any material. To make the fuzz appear on your geometry, connect the Fuzz node to the Geometry socket of the root Material node.

Materials

Gem

Roughness on this type of material will spread out highlights on the surface similar to what you see on other, non-transparent, materials. However, it also spreads out the light that is transmitted through the material. This is used to create a frosted glass look.

Materials

General Parameters

Each material has its own set of parameters, which can be adjusted to get the exact appearance you are going for.

Materials

Generic

The Generic material type is based on the Disney BRDF shader. When you use the Material Importer to import materials such as a Unified 3D Material (.u3m) or Substance Painter Project (.sp) their properties will be mapped to the properties of the Generic material.

Materials

Geometry Node Types

The Geometry nodes will transform the shape of your geometry in a non-destructive manner. This way you can always replace the material and the geometry will return to the original shape.

Materials

Glass

This sets the overall color of the glass material. Click the color box to open the Color Picker and select your desired color.

Materials

Glass (Solid)

This controls the overall color of this material type. When light enters the surface, it will take on the color set here. The amount of color that you see in this material is highly dependent on the transparency setting as well. If you have set a color, but it looks too faint, skip down to the transparency section.

Materials

Ground

Controls the contrast for specular reflections. Can be used to enhance reflections on light backgrounds.

Materials

IES Light

When using IES Light, you will need to load an IES profile by clicking on the folder icon in the editor. As soon as you load the profile you will see the shape of the IES profile in the material preview. You will also see the shape in form of a mesh in the Real-time View.

Materials

In-Project Library

The “In-Project Library” is found in the lower half of the Scene tab (under materials) and in the Material tab below the properties of the current material. Here all materials in the scene will be represented in the form of material ball thumbnails or in a list view.

Materials

Light Sources

In KeyShot Studio, physical lights are designed as materials that may be applied to parts. Any geometry can be turned into a light source. You can either import new geometry, use existing geometry or add a primitive (Edit > Add Light…). Light sources are labeled in the Project Window > Scene Tree by a light bulb ico...

Materials

Link Duplicate Materials

The Link Duplicate Materials feature enables you to quickly locate and link materials from your scene, that are exactly the same. This can be an easy way to help clean up your In-project Library.

Materials

Liquid

This controls how much light will bend or “refract” as it passes through parts that have this type of material.

Materials

Mapping 2D

This node enables you to synchronize and control the position of your textures and labels in one place.

Materials

Material Graph

The Material Graph facilitates advanced material editing/creation. The feature is available only for users of KeyShot StudioPro.

Materials

Material Graph Node Groups

Node Groups are customizable, collapsible node containers, that can help you keep your Material Graph organized and tidy. Node Groups also make it easy to reuse parts of your Material Graph.

Materials

Material Graph Nodes

Nodes are displayed as boxes in the Work Area. Each node has different input and output channels (sockets) depending on the type.

Materials

Material Graph User Interface

There are five components of the Material Graph window: Menu bar, Ribbon, Materials & Textures Library, Material Properties, and the Work Area. Each area is explained below.

Materials

Material Library

In the KeyShot Studio Library’s Material tab you can find a number of material presets, that you can apply to your model.

Materials

Material Node Types

Initially, setting up material nodes is the same as setting up materials in the Material tab of the project panel. But with the Material Graph you can set up much more advanced materials using a combination of nodes. One thing you can do is add multiple bump textures to your material using Utility nodes.

Materials

Material Types

Material Types bring the power to quickly apply real world, physically accurate material properties to your parts. Each Material Type comes preset with settings to quickly apply or change material with the option to adjust each setting as desired. There are four categories of KeyShot Studio Material Types.

Materials

Materials

The sections here cover where to find materials, how to work with materials, general material parameters, and all of the material types and their parameters. Since KeyShot Studio is designed for anyone to create realistic visuals, an understanding of these concepts is not necessary, but can help you gain a deeper un...

Materials

Measured

Materials

Metal

The Metal material type gives you the option to control the metal by Color or by Measured material preset or by importing a complex IOR file.

Materials

Metallic Paint

The clear-coat settings control the top clear-coat layer. Settings are unit-aware and can have a bump map applied that does not affect the base coat.

Materials

Multi-Layer Optics

Allows you to enter/edit the entire material, including all layers in plain text.

Materials

Multi-Materials

Any material can be turned into a Multi-Material (Pro feature) to facilitate non-destructive material swapping, variations or color studies. The Multi-Material allows you to cycle through a variety of materials within a single “container” material.

Materials

OpenPBR

OpenPBR is a surface shading model that is developed by the Academy Software Foundation as a standard for Computer graphics. The goal is to ensure accurate modeling of most computer graphic materials across different tools.

Materials

Paint

This controls the intensity of the clear-coat. 1.5 is a good general starting point. If a more shiny paint is desired, increase the value. Bringing the value down closer to 1 reduces the clear coat effect. This can be useful for making a matte finish.

Materials

Planar Light

Similar to an Area Light, the Planar Light is a material type that will give you diffuse lighting. It will also function similarly to a flood light, but gives you additional flexibility through its spread angles.

Materials

Plastic

This controls how much light will bend or “refract” as it passes through parts that have this type of material. The default of 1.5 is accurate for simulating most types of plastics, but you can increase the value to create a more dramatic refraction within the surface.

Materials

Plastic (Cloudy)

This sets a specific color for the internal cloudiness of the plastic.

Materials

Plastic (Transparent)

The Plastic (Transparent) material provides the basic settings needed to create simple plastic materials. Set the diffuse (overall color) and add some specular (reflections), then adjust the roughness. This is a very versatile material type that is used for anything from concrete to woods.

Materials

Point Light

Here, you can choose the color the light will cast. For accurate lighting colors, use the Kelvin scale to select accurate lighting temperatures.

Materials

Poliigon Textured Materials

Poliigon textures in KeyShot Studio are encrypted and can only be used inside KeyShot Studio. Below is a cross-reference for all KeyShot Studio Materials using Poliigon textures, If you need the textures for other purposes.

Materials

Random Color

Add color randomness to geometry that is assigned a solid color, texture map, or procedural texture. This node allows to randomize hue, saturation and value on a per-curve basis. This can be useful to create additional detail and variation in otherwise homogeneously colored curves.

Materials

Random Texture

The Random Texture node allows you to add texture variations to your parts and make them look more natural. Simply feed multiple different texture maps into the Random Texture node before connecting it with a part.

Materials

Random Value

The Random Value node allows you to randomize most inputs in the Material Graph. You can set a range between a minimum and a maximum value, this will assign each part a random value within that range.

Materials

RealCloth

The RealClothTM procedural material enables you to create woven fabrics, with your custom weave patterns, detailed down to the ply. And make the cloth appear even more tactile with flyaway fibers.

Materials

Refractive Index

Refractive Index is a material parameter that is found in multiple KeyShot Studio material types. The term might not be familiar, but refraction is something that is seen every day. A good example is when a person sticks their hand in a pool. The light is bent, or “refracted” and the arm looks broken.

Materials

Roughness Parameter

The Roughness parameter is another setting that will be found on multiple material types in KeyShot Studio.

Materials

Saving Materials

Once you have gone through either step, a dialogue will prompt you to designate a destination folder in the material library. After the folder location has been selected, the new material will be saved to the library.

Materials

Scattering Medium

With scattering medium you can simulate particle scattering to create such effects as fog or smoke or volumetric lighting such as visualizing beams or rays of light.

Materials

Special Materials

Materials

Specular Parameter

The Specular parameter is another parameter that will be found with many material types.

Materials

Spotlight

Sets the angle that determines the size of the beam – the higher the angle the wider the beam.

Materials

Texture Node Types

Initially, texture nodes are the same as adding textures in the Material Tab of the Project panel. But with the Material Graph you can set up much more advanced materials using a combination of nodes. One thing you can do is add multiple bump textures to your material using Utility nodes.

Materials

Thin Film

Materials

Toon

This will control the number of interior contour lines in the toon sketch. The value determines the angle of the curvature where contour lines will appear. A lower value will increase the number of interior contour lines and a higher value will decrease the number of interior contour lines.

Materials

Translucent

This controls how deep light penetrates into and through the surface depending on the units set under Edit > Set Scene Units. The higher your translucency value, the more of the subsurface color you will see coming through the surface. Higher translucency values will also create a softer looking material.

Materials

Translucent Medium

The TranslucentMedium material type provides control over subsurface scattering properties that are found in many skin, plastic and other materials. Compared to the basic Translucent material type, this generally will resolve faster.

Materials

Utility Node Types

Utility nodes allow you to combine, modify and add to other node types.

Materials

Velvet

This is light that is scattered across the entire object and is especially apparent in the shadowed areas of the object. It can be used to give an overall soft look to the surface. The color of the backscatter light is set with the sheen control.

Materials

Wireframe

This controls the overall color of material, excluding the wires.

Materials

Xray

Materials