Skip to content
07-848 2005

SketchUp support

SketchUp desktop

Model, document and customise your desktop workflow.

Articles in this category

3D Printing a Model

Before you print a model on a 3D printer, you need to make sure your 3D printer can understand your model data. Here's a quick overview of how to set up your SketchUp model for 3D printing:

SketchUp desktop

AI Assistant

The AI Assistant () brings access to AI-powered workflows without leaving SketchUp. To get started with AI Assistant, open SketchUp AI () and select AI Assistant or from the menu by selecting Extensions > AI Assistant.

SketchUp desktop

AI Help

Help in AI Assistant enhances your workflow and saves you time by providing immediate in-app support. With Help, you can find advice on best practices, troubleshoot issues that come up, or even discover new ways to use SketchUp you haven’t thought of, all without interrupting your workflow.

SketchUp desktop

AI Render

SketchUp AI Render integrates generative AI into the SketchUp you know and love to help accelerate the creation of compelling visuals whenever you need them. Whether you are suffering from a block in your creative process, need some extra visuals to help support the narrative you’ve established in your project, or just

SketchUp desktop

AI Render Gallery

At launch, AI Render captures an image of the current viewport of your model in the Preview pane.AI Render uses that viewport as the original input for any generated output. After generating output, generated images will appear in the Gallery.

SketchUp desktop

Adding Attributes

Attributes make components dynamic by telling SketchUp what to do. You can choose from predefined attributes or create custom attributes:

SketchUp desktop

Adding Premade Components and Dynamic Components

Components in SketchUp turn geometry in a model into reusable entities. For example, most buildings have at least one door and window. Instead of modeling these common objects, you can insert a component that you have already made, or even one made by someone else.Like all geometry in SketchUp, a component is still

SketchUp desktop

Adding Text, Labels, and Dimensions to a Model

In SketchUp, you can add four types of text:

SketchUp desktop

Adding an Environment to a Model

Environments allow you to add 360°panoramic backgrounds and image-based lighting conditions to your SketchUp models. The Environments panel is where you can add and manipulate environments, or import High Dynamic Range Image (HDRI) files or OpenEXR files to create a new environment.

SketchUp desktop

Adjusting a Components Insertion Point

A component has its own axis origin point, which determines the component's insertion point, or the point that's loaded onto the Move cursor when you place a component in your model.If the component is box-shaped (such as a dresser or cabinet), the insertion point is typically the front, lower-left corner, as shown in

SketchUp desktop

Adjusting the Drawing Axes

The red, blue, and green axes in a SketchUp model are not only starting points. These axes also serve as guides you can use throughout the modeling process. Some examples of how using the drawing axes can help with your workflows include:

SketchUp desktop

Alternative Revit to SketchUp Options

Incorporating your Revit project with your SketchUp model can be a great way to help with client feedback, design reviews, or stakeholder presentations. Here are just a few reasons you may want to use a Revit file in SketchUp:

SketchUp desktop

Analysis Hub

One of the goals of efficient architectural design is to achieve a sufficient and uniform distribution of natural light throughout internal and external spaces, minimizing the presence of zones that are too bright or too dark.

SketchUp desktop

Analysis Mode

Analysis ModeWhich Analysis Mode you choose can affect the speed of a simulation. The dropdown menu at the top of the plugin provides four Analysis Mode options:

SketchUp desktop

Animating Scenes

Animating scenes can be a great way to show off your model from different angles or with different styles. After Creating a Scene, you can create an animation in one of three ways:

SketchUp desktop

Applying Dashed Lines to Tags

In SketchUp, the Tags Panel has options to give your tagged entities dash patterns. With these dash patterns you can define property boundaries, identify entities that are temporary, or create a grid or reference lines.

SketchUp desktop

Applying Materials

Applying materials to your model is simple:

SketchUp desktop

Basic Edits

You can edit a component as a whole or edit individual entities within a component.Editing or modifying a component instance as a whole affects only the component instance, not the component definition or other instances. Here are some of the edits you can make to a component as a whole:

SketchUp desktop

Best Practices for Custom Prompts

When creating a text prompt it’s important to provide clear instructions through natural language. Here are a few things to keep in mind:

SketchUp desktop

Best Practices for Gaussian Splats

The Gaussian Splatting for SketchUp extension allows you to import, view, and manage Gaussian Splat files directly inside your models. To generate a splat, you must use a dedicated third-party tool.

SketchUp desktop

Best Practices for Trimble Site Contractor

Modeling rules and guidelines for creating models that Trimble Site Contractor (TSC) exports correctly.

SketchUp desktop

Calculating Material Area

If you want SketchUp to calculate the surface area painted with a material, you can context-click the material and select Area > Material.

SketchUp desktop

Casting Real-World Shadows

With SketchUp's Shadows feature, you can make your model cast a basic shadow or see how the sun casts shadows on or around a geolocated model. With Shadows you can get a general idea of how the sun or shadows will look in a specific location at a specific time of day.

SketchUp desktop

Changing a Single Component Instance

Say you want to edit only one instance of a component. For example, perhaps you want to model two or more picket styles so that you can experiment with the options. Follow these steps to edit one instance but leave the other component instances as they are:

SketchUp desktop

Choosing a Style

Styles in SketchUp are a great way to help you convey information about your model without saying a word. A Style is a collection of specific settings for edges, faces, and backgrounds.

SketchUp desktop

Choosing an Analysis Type

The Analysis Hub opens in its own window in SketchUp. The first time you open the Analysis Hub, you’ll see all the available analysis types laid out in a grid. You can choose which type of analysis you want to perform by clicking one of the tiles.

SketchUp desktop

Classifying Objects

SketchUp’s Classifier embeds data into groups or components. Adding this data can help you track and manage every aspect of your model. You can also use this data in Building Information Modeling (BIM), a common workflow used when creating realistic models that incorporate real world, practical data.With SketchUp’s

SketchUp desktop

Classifying Objects in SketchUp

Before you start classifying objects, make sure your model is ready using these guidelines:

SketchUp desktop

Clearing Geolocation Data

Clearing Geolocation DataYou can clear geolocation data from your model at any time from either Add Location or Model Info.Clearing Data Using Add LocationTo clear data using Add Location:

SketchUp desktop

Collaborate in SketchUp

Collaboration is an important part of the design process. SketchUp’s collaboration features make it easy to share your models and collaborate with your peers and stakeholders.

SketchUp desktop

Commenting on a Model

The Comment Tool () creates 3D comment markers in a model. You can leave comments for yourself, or share your model to invite collaborators to view and leave comments. The Comments panel, available in the Collaboration Bar for model owners or as a panel option to viewers, is an easy way to view and manage comments.

SketchUp desktop

Component Axes

In dynamic component development, it is crucial to remain aware of component axes. Proper management of these axes ensures they work in your favor, rather than causing unintended issues. Before you create one attribute, review the following tips for keeping the axes on your side:

SketchUp desktop

Components

Components are complex entities you can create by grouping geometry. When you create a basic component in SketchUp, you turn that grouped geometry into a reusable and separate entity. Adding attributes to a basic component creates a configurable Dynamic Component.

SketchUp desktop

Connect and Collaborate

Collaboration and feedback can be important for a wide variety of projects. SketchUp offers a few different ways you can work with others. Trimble Connect, along with SketchUp’s Collaboration tools, can help you share your designs with stakeholders and peers, ask them for feedback, and even show off your ideas all in

SketchUp desktop

Constraining Attributes of a Dynamic Component

A constrained dynamic component is a component that has elements (sub-components or sub-groups) that, when scaled with the Scale tool, will not change size or orientation to the axes. To constrain entities of a dynamic component:

SketchUp desktop

Controlling Visibility with Tags

What Happened to Layers? SketchUp’s Tags are an updated form of what was called Layers in older versions. Tags provide the same functionality that Layers provided and more.Tags help you organize the objects in your SketchUp model and control their visibility.

SketchUp desktop

Create Your Own Materials

SketchUp’s material libraries offer a variety of useful materials that you can add to your models. To meet your design intent, you may need to create materials using 2D image files as a starting point.

SketchUp desktop

Creating 3D Terrain

SketchUp provides everything you need to create your own terrain for your model using the Sandbox tools.Tip: The Sandbox tools are available as a toolbar you can add in View > Toolbars. The From Contours and From Scratch tools can also be found in Draw > Sandbox.Creating terrain can be useful when:

SketchUp desktop

Creating Common Types of Dynamic Components

Developing your own dynamic components can help you bring your unique vision into your designs. To help you create dynamic components that work for your designs, we’ve put together some information to help with some common workflows:

SketchUp desktop

Creating Scenes

Scenes help you save different model views and properties. You can then present those views to show off different aspects of your model. Each scene you create appears in a tab along the top of the modeling window, allowing for easy navigation and management.With scenes you can:

SketchUp desktop

Creating a 3D Model

Creating a 3D model is easy with SketchUp, but it can be a lot easier when you know about basic modeling techniques. Then, once you know the basics, you can dive into some of the more advanced techniques to help create stunning models for your projects.

SketchUp desktop

Creating a Basic Component

When you transform SketchUp geometry into a component it takes on the following behaviors and capabilities:

SketchUp desktop

Creating a Dynamic Component that Snaps to a Specific Size

You can constrain a component to a series of predefined sizes by placing specific formulas in the LenX, LenY, or LenZ fields of the parent component.Snapping to the nearest rounded valuePlace the following formula in the LenX field for a component to snap the component's LenX to the nearest width within 2 inches after

SketchUp desktop

Creating an SKC File

In SketchUp, the .skc file format stores the classification data that you see in the Classification tool. Each .skc file contains XML schema definition files and other files that help define additional schema metadata. All these files are zipped up in one file.

SketchUp desktop

Creating and Editing a Style

SketchUp provides a lot of styles to choose from by default. If those don’t quite fit the needs of your design, you can always edit them, or even create a new one. To get started, open the Styles panel and follow these steps:To create a new style click Create New Style () on the Select tab.

SketchUp desktop

Creating and Using Section Planes

In SketchUp, section planes cut a model along a plane so that you can peer inside the model without moving or hiding any geometry. In a 3D model, an active section plane hides everything on one side of the plane, as shown in the following figure.You can use section planes for all types of applications:

SketchUp desktop

Customizing Modeling Settings to Complement a Style

Certain styles may not be compatible with SketchUp's default settings for selection colors, hidden geometry display, section planes and cuts, guides, and other features.

SketchUp desktop

Customizing a Model’s Background with Styles

A big part of your model's style is what you see in the background. SketchUp makes it easy to customize the background including the sky, horizon, and ground to best fit the style of your model. After all, what's the use in making a Mars Rover if it doesn't look like it's on Mars?

SketchUp desktop

Defining Attribute Values

After you set up an attribute or three, you’re ready to enter values that tell the attributes what to do. You can complete this step in a myriad ways, depending on the attributes you choose.You can define attribute values in the following ways:

SketchUp desktop

Deleting Imagery

Imported imagery is an entity just like everything else in your model. To delete imported map imagery:

SketchUp desktop

Designing an Analysis Ready Model

When you are ready to perform an analysis there are a few guidelines you can follow to help make sure your results are accurate as possible:  Geolocate your model – Use SketchUp’s Add Location feature to place your model. That location’s latitude and longitude will then be used to provide your analysis data.

SketchUp desktop

Dividing, Splitting, and Exploding Lines and Faces

As you draw 3D models in SketchUp, dividing edges and faces can help you create and manipulate your geometry in complex ways. You can also explode entities, such as circles and polygons, into their individual segments.Dividing a Line or ArcSketchUp splits a line segment when a new line is drawn perpendicular to that

SketchUp desktop

Drawing Arcs

Your model is more than just straight lines. SketchUp can help you create curved geometry using arcs. Check out this square one YouTube video to learn the basics of using the arc tool.

SketchUp desktop

Drawing Basic Shapes

Many models start with basic shapes. In SketchUp, the shape tools help you draw rectangles, circles, and polygons. You find these tools on the Getting Started toolbar, the Drawing toolbar, and the Large Tool Set toolbar.Drawing a rectangle or squareIn SketchUp, you can draw rectangles pretty much anywhere:

SketchUp desktop

Drawing Freehand Shapes

With SketchUp's Freehand tool (), you can create hand-drawn lines. The Freehand tool is handy when you need to trace imported drawings, create a 2D sketch, or decorate your model.

SketchUp desktop

Drawing Lines, Shapes, and 3D Objects

No matter how simple or complex your model, every model in SketchUp is really just edges and faces. SketchUp’s drawing tools help you create those edges and faces.Starting OutIf you’re a beginner to drawing in SketchUp, start simple.

SketchUp desktop

Dynamic Component supported functions

Following is a list of all functions supported within your dynamic components. Many of these functions are identical to functions found in spreadsheet applications such as the spreadsheet application that is a part of Google Docs.

SketchUp desktop

Dynamic Component supported operators

Following is a list of all operators supported in dynamic component formulas.+ (add)- (subtract)* (multiply)/ (divide)< (less than)> (greater than)= (greater than or equal to)= (equal)() (parentheses) (not equal to)

SketchUp desktop

Dynamic Components Logical Function Examples

Logical Functions (for math-related use)FunctionDescriptionExample(s)AND(logicalValue1, logicalValue2, ...logicalValueN)The AND function returns TRUE if all arguments are TRUE. If any element is FALSE, this function returns the FALSE value.

SketchUp desktop

Dynamic Components Math Function Examples

Math Functions SketchUp Functions Text Functions Trig Functions Logical Functions OnClick Functions Math Functions (Specific to SketchUp Dynamic Components) Function

SketchUp desktop

Dynamic Components OnClick Function Examples

OnClick FunctionsFunctionDescriptionExample(s)ALERT("message")The ALERT function displays the value of the message in an alert box.Example: =ALERT("You Clicked Me!")

SketchUp desktop

Dynamic Components SketchUp Function Examples

Math Functions SketchUp Functions Text Functions Trig Functions Logical Functions OnClick Functions SketchUp Functions (Specific to SketchUp Dynamic Components) Function

SketchUp desktop

Dynamic Components Text Function Examples

Math Functions SketchUp Functions Text Functions Trig Functions Logical Functions OnClick Functions Text Functions Function

SketchUp desktop

Dynamic Components Trig Function Examples

Trig FunctionsFunctionDescriptionExample(s)ACOS(number)The ACOS function returns the inverse cosine of the number in degrees.View SketchUp Example

SketchUp desktop

Dynamic Components supported HTML tags

This is a Pro only feature.The following HTML tags are supported within a Dynamic Component's Description and Summary fields:Any tag or version of a tag that is not in this list will be ignored. The following additional rules also apply:

SketchUp desktop

Dynamic component predefined attributes

This is a Pro only feature.Following is a list of all predefined attributes for use in creating your dynamic components.X, Y, ZThe X, Y, and Z attributes contain the value for the component's X (red), Y (green), or Z (blue) coordinate.LenX, LenY, LenZThe LenX, LenY, and LenZ attributes contain the length of the

SketchUp desktop

Edge Styles

Edge styles add a different look to the edges in your model. When editing a style, SketchUp provides several options that can change how edges look in your model. The following options are available under Edge Settings in the Styles panel:

SketchUp desktop

Editing All Instances of a Component

To edit all instances of a component, follow these steps:

SketchUp desktop

Editing Components

When you edit a SketchUp component, you can edit the component definition or the instance, or both. Editing the definition changes every component instance in a model.

SketchUp desktop

Editing Materials

The Edit tab of the Materials panel provides plenty of options to adjust materials to better suit your intentions or desired look and feel.

SketchUp desktop

Editing a Component with Solid Tools

When you edit a component with the Solid tools, the steps are little different than the steps for editing components with the other drawing tools.

SketchUp desktop

Entity Palette

Entity PaletteSefaira attempts to assign the correct type to each entity in a model. If certain entities need to be ignored, or the entity needs to be changed manually, the Entity Palette can help with that. Clicking Show Entity Types color codes all entity types in a model allowing for easy identification.

SketchUp desktop

Erasing and Undoing

Everyone makes mistakes. In SketchUp, you can correct mistakes with the Undo command or the Eraser tool.Using the Undo CommandThe Undo command reverses your most recent action. For example:

SketchUp desktop

Estimating Height

Estimating building height accuratelyIf you don’t know the height of an existing building that you’re trying to model, here are some techniques you can use to make an educated guess:

SketchUp desktop

Evaluation Mode

Evaluation ModeSefaira’s Evaluation Mode allows SketchUp subscribers a chance to preview the features of Sefaira before purchasing a subscription. Evaluation Mode provides a look, with no time limit, at all functions available in Sefaira using a fixed location, Suceava, Romania.

SketchUp desktop

Exporting FBX Files

In SketchUp Pro, you can export a SketchUp file to the FBX format, which is a proprietary Autodesk format.The idea behind FBX is that, if you’re creating a film, game, or similar 3D content, you (and a team of other people) likely need to use several applications in your workflows.

SketchUp desktop

Exporting KMZ Files for Google Earth

Google Earth is a great tool for viewing a model in the context of its intended surroundings, such as the buildings on a city block. Although SketchUp has built-in tools for viewing your model in Google Earth, you might need to export a KMZ file if:

SketchUp desktop

Exporting OBJ Files

If you’re a SketchUp Pro user, you can export files in the OBJ format.Wavefront Technologies developed the OBJ file format for its Advanced Visualizer software, and over time, other 3D software developers have adopted the open OBJ format. OBJ files are text-based and support free-form and polygonal geometry.

SketchUp desktop

Exporting SketchUp Files to Revit

When exporting a SketchUp file to Revit, there are a few things to keep in mind:

SketchUp desktop

Exporting VRML Files

If you’re a SketchUp Pro user, you can export your SketchUp models to a VRML file, which has the .wrl file extension.VRML 2.0 (Virtual Reality Modeling Language) is a 3D scene/object description format often used to exchange data between 3D applications and to publish 3D information online.

SketchUp desktop

Exporting XSI files

XSI files are used with Autodesk Softimage, an application filmmakers, video game designers, and advertising firms use to create 3D content. Although the use of Softimage has declined and Autodesk plans to deprecate Softimage in 2016, you may need an XSI file if you still use Softimage in your workflows.To export an

SketchUp desktop

Exporting a SketchUp Model to LayOut

SketchUp and LayOut are designed to work together. In SketchUp, the easiest way to send your models over to LayOut is Send to LayOut (). You can find this option in the following locations:

SketchUp desktop

Extending SketchUp

SketchUp already offers a lot of options when it comes to enhancing models. Other SketchUp products and features like LayOut, Style Builder, 3D Warehouse already provide additional tools to elevate models created in SketchUp. If those options don’t have what you need, SketchUp offers a few more products and features.

SketchUp desktop

Extruding with Follow Me

The SketchUp Follow Me tool () leads a face along a path to create a 3D shape. The Follow Me tool does only one thing. However, it has a multitude of applications and can help you draw complex 3D models with only a few clicks.

SketchUp desktop

Face Styles

You can edit any of SketchUp’s default styles to better match your workflow. When editing a style, SketchUp provides options that can change how faces look in your model.The following style options are available under Face Settings in the Styles panel:

SketchUp desktop

Finding and Using Add Location

To get started with Add Location, select File > Add Location from the Menu bar.Another way to open Add Location is in Model Info. From the menu bar click Window > Model Info. Select Geo-location from the options on the left of the window and click Add Location.

SketchUp desktop

Flipping, Mirroring, Rotating and Arrays

With SketchUp's flipping and rotating tools, your geometry becomes as nimble as an acrobatic troupe. The Flip Along command enables geometry to backflip 180 degrees along any axis. With the Rotate tool, your geometry can spin and fold like a professional gymnast.

SketchUp desktop

Frequently Asked Questions

Frequently Asked QuestionsIs Sefaira available with a SketchUp subscription?Sefaira requires its own subscription and is not available as part of any commercially available SketchUp subscription.

SketchUp desktop

Gaussian Splats in SketchUp

Gaussian Splatting is a cutting-edge 3D representation technology that takes 2D images or video and creates high-resolution, photorealistic 3D environments. You can think of a Gaussian Splat as an advanced 3D point cloud made up of millions of tiny, semi-transparent elliptical blobs or "splats".

SketchUp desktop

Generate Object

Adding realistic 3D assets to your model can be time-consuming. Even if you find an object you like in 3D Warehouse, it may not match the vision for your design. With Generate Object, you can use SketchUp AI to create 3D assets with photoreal materials based on an image or text prompt.

SketchUp desktop

Generate Textures

With Generate Textures, SketchUp can help you create Physically Based Rendering (PBR) texture maps for materials that don’t have them. With the help of AI, SketchUp will analyze your material and create corresponding texture maps for Metalness, Roughness, Normal, and Ambient Occlusion.

SketchUp desktop

Generated Object Gallery

Once you generate a model you can view it in the Gallery ().

SketchUp desktop

Generating Custom Output

AI Render offers a few different ways you can generate or refine an image.

SketchUp desktop

Generating Gaussian Splats

The Gaussian Splats for SketchUp extension focuses on visualizing and manipulating splat files. If you need to generate your own .ply, .splat, or .spz files, you’ll need to use a third-party tool.

SketchUp desktop

Generating an Attribute Report

With the Generate Report feature, you can create a report that lists component attributes and download the report as a CSV file. Generating a report is a quick and easy way to see quantities, materials, and other data about items in a SketchUp model.

SketchUp desktop

Geolocating with Add Location

The first page you see when launching Add Location is Geolocate Model. Begin by narrowing down your location. Add Location will use your current location by default. You can specify a specific address, zip code, or location name in the box provided. As you type, SketchUp offers suggestions that match what you entered.

SketchUp desktop

Geolocation and Terrain

Geolocating a model or adding terrain puts your SketchUp design into real-world surroundings. By using SketchUp’s Add Location feature, importing data or site context, or creating your own terrain, you can enhance your model with specific and accurate location data and site context.

SketchUp desktop

Geolocation in Model Info

The Model Info window contains several sections that detail all the behind the scenes information of your model. You can open Model Info in the menu bar by selecting Window > Model Info.

SketchUp desktop

Geolocation in SketchUp

Getting Started with GeolocationSketchUp’s Add Location feature helps you to capture geolocation data and apply it to your model. You can also import content into your model that’s already been geolocated. To get started take a look at these articles:

SketchUp desktop

Getting Scan Essentials

DownloadingScan Essentials is only available with a SketchUp Pro Scan, SketchUp Pro Advanced Workflows, or Studio subscription.

SketchUp desktop

Grouping Geometry

In SketchUp, grouped geometry is called an Object. There are two types of Objects, Groups and Components. Groups are just what they sound like they are, a selection of multiple pieces of geometry. Components are more complex, reusable Objects. Both types of Objects can help you organize your model in a few ways:

SketchUp desktop

Hiding the Scale Handles in a Dynamic Component

This is a Pro only feature.Add the Scale tool attribute to your Dynamic Component to toggle display of scale handles on the component (limiting how users can scale the component). To hide scale handles using the Scale tool attribute:

SketchUp desktop

Hierarchies in the Outliner

With the Outliner in SketchUp you can view a model's groups, components, and section planes in a hierarchical tree. The Outliner panel makes it easy to:Navigate around and identify objects in large models.Name objects and section planes.Find components or section planes.Restructure the model hierarchy.Control the

SketchUp desktop

Image Object Generation

If you want to use an image to generate an object there are a few things to keep in mind:The image must be a .png, .jpg, .jpeg, or .heic file.The image must be 50MB or less.An image with a white background works best.To use an image to generate an object:Open SketchUp Assistant and select the Generate Object tab ().

SketchUp desktop

Implement Dynamic Pricing

You can create a component whose pricing changes based on the type of material or size of component the user chooses. To implement dynamic pricing in your dynamic component:Create a component, such as a cabinet door.

SketchUp desktop

Importing DEM Files for Terrain

SketchUp can import digital elevation models (DEM), which contain point data relating to terrain elevations. DEM files don’t come in a standardized format, but SketchUp supports the import of two file types:

SketchUp desktop

Importing Geolocated Content

Importing FilesWith SketchUp, you can import files that already include geolocation data or have been positioned in real-world locations. This includes other SketchUp files, and even files created with other software.

SketchUp desktop

Importing Revit Metadata

When exporting a SketchUp file to Revit, there are a few things to keep in mind: A well organized model will help make the transition from SketchUp to Revit a success. Make sure you know which version of Revit you are using.

SketchUp desktop

Importing a Revit File

For SketchUp Studio subscribers using Microsoft Windows, our Revit Importer makes it easy to import your Revit project into a SketchUp model.

SketchUp desktop

Importing and Exporting 3DS Files

The 3DS format is native to the original DOS-based 3D Studio modeling and animation application. 3DS offers a direct way to export simpler SketchUp models into a wide range of 3D modeling packages.

SketchUp desktop

Importing and Exporting CAD Files

The most common CAD formats are .dwg and .dxf. These formats are proprietary and most often associated with Autodesk and AutoCAD, but other programs also use them.

SketchUp desktop

Importing and Exporting COLLADA Files

COLLADA is an XML-based schema that enables you to transfer data among 3D digital content creation tools, such as SketchUp, Maya, 3ds Max, and Rhino. COLLADA files use the .dae file extension, which stands for digital asset exchange.In SketchUp, you can import and export COLLADA files pretty easily.

SketchUp desktop

Importing and Exporting IFC Files

The Industry Foundation Classes (IFC) file type is a standardized data format used in BIM. IFC files contain detailed information about things like building components, geometry, and even price data.

SketchUp desktop

Importing and Exporting Image Files

In SketchUp you can import images to create custom textures that you apply to faces in your 3D model. You can also export images to share a model.You can work with images in an array of file formats:

SketchUp desktop

Importing and Exporting STL Files for 3D Printing

In SketchUp, you can import and export STL files, which are used in 3D printing. As explained in 3D Printing a Model, for a SketchUp model to become a successful 3D printout, the model needs to meet certain criteria, such as having a base and a volume and being a solid.Importing an STL file into SketchUpTo import an

SketchUp desktop

Importing and Using 2D Images

You can import and use 2D images in a SketchUp model in a variety of ways:

SketchUp desktop

Importing, Exporting, and Deleting Classifications

ImportingTo import a classification into a SketchUp model, follow these steps:

SketchUp desktop

Inserting Components

You can insert a component instance into your model by selecting an existing component in the Components panel, by importing a saved component file into your model, or by downloading the component from 3D Warehouse.To insert a component using the Components panel, follow these steps:

SketchUp desktop

Inspecting an Entity

As you create 3D models in SketchUp, you create an entity whenever you draw a line or face. Combining lines and faces into a group or component creates a special group or component entity.Each entity in a model has attributes, such as its measurement, the layer it's on, and more.

SketchUp desktop

Interacting with Dynamic Components

Your ability to interact with a dynamic component depends on its variables. To help you understand how this works, take a look at this basic building with two instances of a dynamic door component.

SketchUp desktop

Introducing Drawing Basics and Concepts

Drawing a model in 3D is different from drawing an image in 2D. This introduction to drawing basics and concepts explains a few ways you can create edges and faces, (the basic entities of any SketchUp model and also discover how the SketchUp inference engine can help.

SketchUp desktop

Letting the Fog Roll into Your Model

The Fog panel helps you add an effect that mimics real world fog in your model. With Fog enabled, your model becomes clearer as you zoom closer to it, and less clear as you move away. To add fog-like effects to your model, follow these steps:

SketchUp desktop

Making Attribute Values End-User Configurable

You might want to allow the users of your dynamic component to configure some values of your dynamic component, such as the spacing between pickets in a fence or the width of your stairs. Values that are configurable will appear in a Component Options dialog box accessible from the component's context menu.

SketchUp desktop

Making Components

Creating ComponentsComponents can be made by selecting all of the edges and faces of an object, or a set of objects, and then right-clicking over the highlighted (i.e. selected) objects and selecting Make Component from the menu.

SketchUp desktop

Making a Dynamic Component

When you create a dynamic component you add attributes with specific values to a basic component.For simple dynamic components, the process is easier than you think.

SketchUp desktop

Managing Gaussian Splats in SketchUp

The Gaussian Splatting for SketchUp extension’s toolbar and the Gaussian Splatting Manager both provide tools and options to help you manage your uploaded splat. This includes visibility tools and options, modeling tools, and file management options.

SketchUp desktop

Managing In Model Styles and Collections

In SketchUp, collections help you organize styles and easily access the ones you use most often. SketchUp includes several default collections, but you can create your own and save collections to a favorites list.The In Model styles collection is particularly helpful, because it contains all the styles currently

SketchUp desktop

Managing and Organizing Materials

The Materials panel provides options to help you find and organize materials.

SketchUp desktop

Materials and Textures in the Revit Importer

The Revit Importer analyzes the appearance asset in every material in your Revit file, including the name, base color, and any associated texture image references. SketchUp then uses this data to generate a native SketchUp material that appears in the Materials panel.

SketchUp desktop

Materials, Textures, and Environments

Materials, environments, and textures add images, colors, lighting, and textures to parts of your model. Applying these effects to your models adds an extra level of detail and realism.

SketchUp desktop

Measuring Angles

The Protractor tool helps measure or create angles. You’ll find the Protractor tool () in the following toolbars:Construction toolbarLarge Tool Set toolbarTools menuTool palette (macOS)The Protractor does not have a default keyboard shortcut.

SketchUp desktop

Measuring Distance

The Tape Measure tool can measure a distance, create a guide, or reveal coordinates along an axis. The default keyboard shortcut for the Tape Measure () and the tool can be found in the following toolbars:

SketchUp desktop

Modeling Complex 3D Shapes with the Solid Tools

With SketchUp’s Solid tools, you can create new shapes by combining or cutting one shape with another, making it easy to model an outer shell or joinery.

SketchUp desktop

Modeling Specific Shapes, Objects, and Building Features in 3D

To create a 3D model in SketchUp, you're constantly switching among the drawing tools, views, components, and organizational tools. In this article, you find several examples that illustrate ways you can use these tools together to model a specific shape or object.The examples illustrate a few of the different

SketchUp desktop

Modeling Tips and Tricks

Tip #1: Segmentation If you segment your point cloud in RealWorks and export your project as an .RWP file, the project will retain those segmented portions and allow you to toggle them on and off in the Point Cloud Manager menu.

SketchUp desktop

Moving Entities Around

When you're drawing a model in SketchUp, moving all or parts of your model can be tough, especially when navigating geometry in a three dimensional space. Here's your guide to moving things around in your 3D model, from a simple click-and-move operation to moving precisely with 3D coordinates.To perform a simple move

SketchUp desktop

Navigating the Materials Panel

The Materials panel is where you can find, manage, and create materials to use in SketchUp models. The Materials panel is part of the default tray on Windows. On MacOS, go to Window > Materials, opening the Colors panel.

SketchUp desktop

Offsetting a Line from Existing Geometry

When you create a 3D model, you often need to draw a slightly bigger or smaller version of a shape and keep the two shapes equidistant from each other. This is called offsetting a line. An offset is handy when:

SketchUp desktop

Organizing Component Collections

SketchUp's Components panel can help you organize components into collections. The In Model collection holds all the components saved with your model, even those that don’t appear in your current design. You can also create your own collections to organize components in whatever way makes sense to you.

SketchUp desktop

Organizing a Model

SketchUp provides all the tools needed to keep everything organized. An organized model makes it easier to manage entities and control visibility. To get started, take a look at the following organizational features and techniques available in SketchUp:

SketchUp desktop

Performing an Analysis

After making sure your design is ready for analysis, and choosing which type of analysis you want to run, you’re ready to run your first analysis.

SketchUp desktop

Phases in Revit Importer

Revit's phasing tool acts like a timeline for your project, tracking exactly when parts of a building are built or torn down. Every view you look at is set to a specific point in time, and any wall or door you place automatically gets stamped with that date.

SketchUp desktop

Photo Matching

SketchUp’s Match Photo feature can help you apply a photo to your model, or even create a model from a photo.Match Photo works best when your image meets certain criteria:

SketchUp desktop

Placing Models and Objects on Terrain

After importing or creating your own terrain, you may want to add new entities to your model.

SketchUp desktop

Point Cloud Manager

To open the Point Cloud Manager menu, click on the button. The Point Cloud Manager contains setting options pertaining to how the points in the point cloud will be displayed in the modeling window.

SketchUp desktop

Positioning Textures

After you apply a material with an image texture to one or more faces in a 3D model, you can adjust how that texture displays on a face.To change the position of a texture, context click the face with the material and select Texture > Position.

SketchUp desktop

Precise Modeling with Measurements

SketchUp’s Tape Measure tool, Protractor tool, and the Measurements box help add accurate measurements to your designs. These tools offer several ways to add precision to a model:

SketchUp desktop

Preparing Revit Files for SketchUp

Taking a few minutes to set up your Revit file before opening the Revit Importer helps prevent unexpected results, such as missing texture or unwanted geometry.

SketchUp desktop

Preserving Textures in a Dynamic Component

When purging a model in SketchUp or uploading it to the 3D Warehouse, unused materials will be removed. If your model contains a Dynamic Component, though, you may also lose textures in "Choose Options" or "OnClick" attributes. To avoid losing these textures, you'll need to embed them into the Dynamic Component:

SketchUp desktop

Preset Prompts

Crafting a text prompt for your generated images can seem a bit complicated. To help you generate the stunning visuals you want without getting a degree in prompt engineering, AI Render offers several preset prompts using both regular and negative prompts.

SketchUp desktop

Printing Views of SketchUp Models

When you want to print a view of your model, SketchUp uses the current active view of your mode, the view you see on your screen. If your view is zoomed out, your print will appear zoomed out. If the camera is set to a Top or Iso view, your print will show that view.

SketchUp desktop

Prompt Engineering in AI Render

Prompt engineering is the art of crafting specific inputs, or prompts, that guide an AI model in generating desired outputs. With AI Render, your input prompts describe the visual elements you want in your SketchUp model’s viewport.

SketchUp desktop

Pushing and Pulling Shapes into 3D

With the Push/Pull tool (), you can create a 3D shape from a face or cut a 3D shape out of your model. You can push/pull any type of face, including circular, rectangular, and abstract faces.The video shows you all the tricks you can do with the Push/Pull tool.

SketchUp desktop

Real Time Viewing

By default, your viewers will see your modeling updates in real time. Any change you make will appear to anyone, and viewers can even see the tool you are using to make changes if cursors are visible.

SketchUp desktop

Referencing Dynamic Component Attributes, Functions, HTML Tags, and Operators

To develop your dynamic component interactions, use the following references to the predefined attributes, functions, and operators. These are the building blocks for any dynamic component behavior that you can imagine.

SketchUp desktop

Repeating a Sub-Component Within a Dynamic Component (1 Dimension)

A repetitive dynamic component is a component containing a sub-component that repeats, such as the pickets of a fence component, or the steps of a stair component.

SketchUp desktop

Repeating a Sub-Component Within a Dynamic Component (2 Dimensions)

A repetitive dynamic component is a component containing a sub-component that replicate, such as the tiles within a floor component. In the case of a floor and tiles, the component scales in 2 dimensions, X, and Y.

SketchUp desktop

Replacing Components

You can easily replace the components you place in your model with another one by following these steps:

SketchUp desktop

Replacing a Material

By replacing one material with another you can experiment with different materials in your designs without having to pick each face or group one by one. The Paint Bucket () tool can help you achieve this through its optional tool modes:

SketchUp desktop

Revit Version Compatibility

SketchUp’s Revit Importer supports .rvt files created using Revit 2011 up to the newest versions of Revit available when a new version of the importer is created.

SketchUp desktop

Sample Point Cloud Data

To help you learn Scan Essentials and allow you to experiment and test different modeling techniques, below is an assortment of point clouds for you to download and use with Scan Essentials.

SketchUp desktop

Saving and Sharing AI Render Output

Once you’ve created output using AI Render, you can choose to use it to create a new scene, save the generated output locally, or share it with others.Add SceneWhen you click or tap Add Scene, AI Render creates a new scene in your model.

SketchUp desktop

Scaling Your Model or Parts of Your Model

In SketchUp, you can resize and reshape your model based on the relative sizes of edges and faces. With SketchUp’s scaling tools you can:

SketchUp desktop

Scan Essentials and LayOut

The ability to visualize and interact with a point cloud in SketchUp's modeling environment is extended to LayOut as well. When you insert a SketchUp model that is using a point cloud, the point cloud will also be displayed in LayOut's model viewports. LayOut's tools will refer to the point cloud like real geometry.

SketchUp desktop

Scan Essentials for SketchUp

Scan Essentials provides the ability to import, view and interact with point cloud data in the SketchUp modeling environment. The imported point cloud can be used within SketchUp to model the scanned as-built condition, provide accurate visual context to your existing sketchup model, and to collect accurate measurement

SketchUp desktop

Sculpting and Fine Tuning Terrain

After importing or creating terrain you may need to edit or refine it to fit your needs. With the Sandbox tools native to SketchUp you can transform even a flat Triangulated Irregular Network (TIN) into a fully fleshed out landscape.

SketchUp desktop

Sefaira

What is Sefaira?Sefaira is a powerful tool used for providing building performance analysis of the geometry created in SketchUp. Sefaira can help provide meaningful metrics like:

SketchUp desktop

Sefaira Support

Sefaira SupportIf you need some guidance, are running into an issue, or want to learn more about all Sefaira can do, see the dedicated Sefaira Help Center.

SketchUp desktop

Selecting Geometry

SketchUp offers two tools to help you select what entities you want to modify with SketchUp's other tools and commands - the Select tool (), and the Lasso tool (). Here's where you find these tools in SketchUp:

SketchUp desktop

Sharing Components

You can share your components files with others directly, or through 3D Warehouse. Here are a few things to keep in mind about the way your components are nested before you share:

SketchUp desktop

Sharing Styles

Styles are shared in .style files. You must create a .style file to share a style with others. To share a style:

SketchUp desktop

Sharing a Model

SketchUp’s Collaboration Bar helps you share your designs with, and ask for feedback from peers, stakeholders, or almost anyone. With the Collaboration Bar you can share a private link, or create a link for General Access anyone can view.

SketchUp desktop

Site Context and Terrain

Site Context and 3D TerrainUsing real-world terrain for site context can help you fully visualize your model. That said, sometimes real-world terrain may not be what fits your unique vision. In either case, take a look at these articles to get started importing or creating your own site context:

SketchUp desktop

Site Context with Add Location

A model must contain geolocation data before adding site context. See Geolocation in SketchUp if you still need to geolocate your model. When you open Add Location in a geolocated model the geolocation data will already be there.Click Import Context to continue to Add Site Context.

SketchUp desktop

SketchUp

SketchUp for Desktop is simple, yet powerful, software that can help you create stunning 3D models. With SketchUp you can:

SketchUp desktop

SketchUp AI

AI is transforming the way Design, Engineering and Construction professionals get things done. SketchUp AI integrates this technology into SketchUp. Whether you need to create compelling visuals from your models, or need that perfect asset to add to your design, or even need a little extra help while modeling, SketchUp

SketchUp desktop

SketchUp AI FAQ

New Zealand guidance for SketchUp AI FAQ: PCS billing and subscription actions, with separate procedures for direct Trimble purchases.

SketchUp desktop

SketchUp Connector for Claude

The SketchUp Connector for Claude generates SketchUp files in Claude.Ai. Using the Connector you can: - Build 3D models using basic shapes and curved surfaces. - Organize model geometry into groups and components. - Produce .skp files compatible with all versions of SketchUp.

SketchUp desktop

SketchUp Labs

At SketchUp, we pursue innovation that makes work simpler and more fun for our users. With that in mind, we’ve created SketchUp Labs. SketchUp Labs is a testing ground where we can share the features in development and get them out there into your hands.

SketchUp desktop

SketchUp and Revit

Many SketchUp projects eventually make their way into other programs for detailing and documentation. At the same time, projects from these programs find their way into SketchUp for better visualization, collaboration, and improved communication.

SketchUp desktop

Snaps

A Snap is a custom point you can add to a group or component. Once added, a Snap allows you to both position and orient objects at the same time. Snaps can help you create models with components that are easy to place, layout, or assemble.The Anatomy of a SnapSnaps appear as a disk.

SketchUp desktop

Softening, Smoothing, and Hiding Geometry

Using the Soften Edges feature, along with the Smooth edge property, changes the visibility of edges and can make your model look more realistic with less geometry.

SketchUp desktop

Speeding Up Rendering with Fast Styles

SketchUp Styles can add complexity to a model that slow down SketchUp as you work on your 3D model. To apply the styles you need while optimizing performance, use Fast Style.

SketchUp desktop

Stretching Geometry

When you move geometry that's connected to other geometry, SketchUp stretches your model.To stretch your geometry, select the Move tool (). Clicking and dragging different parts of an entity will give the following results:

SketchUp desktop

Technical Notes

Here are a few questions and answers to help you better understand how AI Render works and how it was built.What Generative AI technologies is AI Render based on?AI Render is a latent text-to-image diffusion model capable of generating photo-realistic images given any text input.

SketchUp desktop

Terrain Visibility

Depending on how complex the terrain in a model is, it can impact performance. Because SketchUp doesn’t render hidden geometry, hiding terrain can help improve performance.

SketchUp desktop

Testing a Dynamic Component

After you define the attributes and values for a dynamic component, test how it works in the Component Options window, which you can open in any of the following ways:

SketchUp desktop

Text Prompt Object Generation

Generating an Object with a Text PromptIf you don’t have an image you want to use, you can always enter in a text prompt that will create an image for you. If you need help with crafting a text prompt, see Best Practices for Custom Prompts.To use a text prompt to generate an object:

SketchUp desktop

The Analysis Viewer

The Analysis Viewer provides a 3D environment where you can interact with your analysis results.

SketchUp desktop

The Sefaira Web App

The Sefaira Web AppThe Sefaira plugin can provide a lot of information about a model’s energy performance. The insights gained from the Sefaira plugin can then be transferred to the Sefaira web app.

SketchUp desktop

Trimble Site Contractor

Trimble Site Contractor (TSC) is a SketchUp extension available as part of the SketchUp Pro Civil Contractor, SketchUp Pro Advanced Workflows, and SketchUp Studio subscriptions.

SketchUp desktop

Updating AI Render

AI Render receives regular updates. On SketchUp for Desktop, AI Render is an extension. That means you'll need to update the extension using the Extension Manager.

SketchUp desktop

Using AI Render

SketchUp for Desktop, SketchUp for iPad, and SketchUp for Web all offer AI Render. How you access and use AI Render depends on the version of SketchUp you are using. In all versions of AI Render, image generation can take between 13 and 20 seconds.

SketchUp desktop

Using Guides

Guide lines are temporary dashed lines you can use as guides to help as you draw. These lines do not interfere with regular geometry. Guide points are standalone points you can use as inferences.Creating GuidesTo create a guide line with the Tape Measure:

SketchUp desktop

Using Scan Essentials

The Scan Essentials toolbar contains everything you need to start using point cloud data in your SketchUp models.

SketchUp desktop

Using SketchUp with Other Applications

Many Sketchup users also use other modeling software or programs as part of their workflows. With that in mind, SketchUp can help you import a file created in another program, or export your model into a different file format.Use the following table to find the type of file you are working with, the SketchUp

SketchUp desktop

Using SketchUp’s Generate Report Service

SketchUp's Generate Report service creates tables of information based on the objects in your models. This is useful for creating materials lists and estimates. Each column in a report corresponds to an attribute from the objects in your model. The rows in the report are the attribute values.

SketchUp desktop

Using Trimble Site Contractor

The Trimble Site Contractor (TSC) extension helps you connect your SketchUp and Trimble Siteworks workflows. After you have prepared your model, you can export it from SketchUp to Trimble Siteworks through the Trimble Site Contractor (TSC) extension.

SketchUp desktop

Using Unique Textures in a Dynamic Component

This is a Pro only feature.Dynamic Components that use unique textures (textures that do not ship with SketchUp, such as photographic textures of a specific material), must be embedded in the Dynamic Component to be accessible when that component is used on different computers.

SketchUp desktop

Using Your Own Image for Site Context

Any topography or images generated with Add Location can be replaced with your own image.After using Add Location, Import the image you would like to add to your model and follow these steps:

SketchUp desktop

Using the Analysis Hub Dashboard

The Analysis Hub dashboard is where  you can view and manage each analysis you’ve performed, create a new one, or start again with a new model snapshot.

SketchUp desktop

Using the Credits feature

The Credits feature helps you list who has contributed to a model. If you claim the credit for a model and upload the model to the 3D Warehouse, anyone who downloads the model will see these credits when viewing the model in SketchUp. To Claim credit:

SketchUp desktop

Using the Measurements Box

The Measurements Box appears in the lower right corner of the SketchUp interface. The way the Measurements Box works changes based on which tool you are using:When you create geometry, you can enter a value in the box and specify precise dimensions.When moving or rotating, you can enter a value to help you position

SketchUp desktop

Viewing a Model

As you create a model in 3D, you need to view it from all sides. In SketchUp, you orbit, zoom, and pan all the time as you draw:

SketchUp desktop

Walking through a Model

A great way to show off your model is to simulate walking through it. The following tools can help you take a virtual tour:

SketchUp desktop

Watermarking a Model

With a watermark you can place a graphic in front of or behind your model. Watermarks can be used to add a company name or logo to identify your designs, but can also have creative applications.To add a watermark to your model, follow these steps:Open the Styles Panel and navigate to the Edit tab.

SketchUp desktop

Working with GLTF Files

A GLB file is a compact, binary version of glTF. GLB files combine models, animations, and physically based rendering (PBR) textures into a single, efficient file. This format is popular in web applications, gaming, and machine learning because of the following advantages:

SketchUp desktop

Working with USDZ Files

A USDZ file is a 3D format that packages everything needed for a model, like geometry, textures, and materials, into a single file. USDZ also supports photo-based rendering (PBR) texture maps like roughness and metalness that help create realistic visuals.USDZ is widely used in VFX and Augmented Reality workflows.

SketchUp desktop